On Wed, Feb 12, 2020 at 09:38:29AM -0600, Eric Blake wrote:
+#ifdef NBDKIT_INTERNAL
+/* Opaque type encapsulating all information needed for calling into
+ * the next filter or plugin.
+ */
+typedef struct backend backend;
+#else
+typedef void backend;
+#endif
Is it better to call it something with an nbdkit_* prefix? Although
not advisable, there can be out of tree filters and we do publish
<nbdkit-filter.h> as a public header file.
Anyway, you decide - ACK patch.
Rich.
--
Richard Jones, Virtualization Group, Red Hat
http://people.redhat.com/~rjones
Read my programming and virtualization blog:
http://rwmj.wordpress.com
Fedora Windows cross-compiler. Compile Windows programs, test, and
build Windows installers. Over 100 libraries supported.
http://fedoraproject.org/wiki/MinGW