This is what I've been playing with in response to my earlier question
about what to do with 'nbdkit -s sh -'
(
https://www.redhat.com/archives/libguestfs/2020-April/msg00032.html)
I'm still open to ideas on a better name, and/or whether adding
<stdbool.h> to our public include files is a good idea (if not,
returning int instead of bool is tolerable).
Eric Blake (2):
server: Add nbdkit_stdio_safe
server: Sanitize stdin/out before running plugin code
docs/nbdkit-plugin.pod | 23 +++++++++++++++++++-
plugins/sh/nbdkit-sh-plugin.pod | 4 +++-
include/nbdkit-common.h | 2 ++
server/internal.h | 2 ++
server/background.c | 12 ++++-------
server/captive.c | 10 +++++++--
server/connections.c | 12 -----------
server/main.c | 38 ++++++++++++++++++++++++++++++---
server/nbdkit.syms | 1 +
server/public.c | 18 +++++++++++++++-
server/test-public.c | 23 ++++++++++++++++++--
plugins/sh/sh.c | 7 +++++-
tests/test-layers-plugin.c | 12 ++++++++++-
tests/test-layers.c | 4 +++-
14 files changed, 135 insertions(+), 33 deletions(-)
--
2.26.0.rc2