Bugzilla:
https://bugzilla.redhat.com/show_bug.cgi?id=1844341
The "iface" parameter of the various "add-drive" actions has never
been
functional: the libvirt backend has always rejected a non-empty "iface",
and the direct backend has never handled it correctly. The parameter
itself is not useful for anything really, so let's just remove all the
logic related to it, beyond keeping the API compatible. Update the docs
as well.
Thanks,
Laszlo
Laszlo Ersek (4):
lib: launch-direct: ignore drive "iface" parameter
lib: drive_create_data, drive: remove field "iface"
lib: rename VALID_FORMAT_IFACE to VALID_FORMAT
tests/regressions: remove "iface"-based restrictions
generator/actions_core_deprecated.ml | 6 +-
lib/drives.c | 35 +++---------
lib/guestfs-internal.h | 1 -
lib/launch-direct.c | 59 +++++---------------
lib/launch-libvirt.c | 6 --
lib/libvirt-domain.c | 15 -----
lib/unit-tests.c | 16 +++---
tests/regressions/rhbz690819.sh | 10 +---
tests/regressions/rhbz975797.sh | 10 +---
9 files changed, 38 insertions(+), 120 deletions(-)
base-commit: 4864d21cb8eb991f0fc98d03a068173837cba50e
--
2.19.1.3.g30247aa5d201