On Fri, Jun 16, 2017 at 03:24:40PM +0200, Pino Toscano wrote:
On Thursday, 15 June 2017 19:05:54 CEST Richard W.M. Jones wrote:
The new module ‘Std_utils’ contains only functions which are pure OCaml and depend only on the OCaml stdlib. Therefore these functions may be used by the generator.
Hm can we please use a better name than Std_utils? Otherwise there's a bit of confusion between two generic names such as Std_utils and Common_utils.
I had another part of this plan which I didn't yet implement (because it's not necessary for getting the inspection stuff rewritten). That was to observe that after all these changes, Common_utils only contains functions like "message", "open_guestfs", "external_command" and others which are only used by the tools, and therefore we could rename Common_utils -> Tools_utils. Granted I haven't done that yet done that, but I think it will make more sense after that (future) change. Rich. -- Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones Read my programming and virtualization blog: http://rwmj.wordpress.com virt-builder quickly builds VMs from scratch http://libguestfs.org/virt-builder.1.html