On 2/25/20 4:30 AM, Richard W.M. Jones wrote:
I like this change. I think we were overloading the config_complete method before to do two different things (complete configuration; do any allocation/housekeeping necessary before we can start serving).
The only questions in my mind are whether we want this before 1.18, and whether the name ("get_ready") is a good one.
I'm not coming up with any better name. Once we release, we're stuck with the name, but I don't see it as too much of a problem. My idea about enhancing filters to get access to next_ops for all filter connections to multiplex on a single plugin is still doable on top (since we don't promise filter API stability), so I don't see any problem with this going in 1.18, if you're ready to include it now. -- Eric Blake, Principal Software Engineer Red Hat, Inc. +1-919-301-3226 Virtualization: qemu.org | libvirt.org