29 Jun
2018
29 Jun
'18
12:18 p.m.
On Thu, Jun 28, 2018 at 11:36:16AM -0500, Eric Blake wrote:
Prefer named constants over magic numbers in the 'struct option' list, and expand the list of enums for long-only options so that the call to getopt_long() can switch directly to every option, rather than needing a lengthy if/else chain that grows for every new long option.
Patch best viewed with whitespace changes ignored.
Interesting, we could use this all over libguestfs too. I didn't know this was possible. ACK. Thanks, Rich. -- Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones Read my programming and virtualization blog: http://rwmj.wordpress.com virt-builder quickly builds VMs from scratch http://libguestfs.org/virt-builder.1.html