On 07/03/16 21:45, Richard W.M. Jones wrote:
Thanks, I have pushed this patch series.
Could you consider changing:
+ optional = Some "icat"; I think it would be nice to have a single feature, and to call the feature "sleuthkit" or "forensics" or something like that. We don't need to have one feature per API since installation of a single package (sleuthkit) is sufficient to make all the APIs available. This was something I was a bit confused about. For what I've got, libguestfs checks the availability of something by inspecting its path.
TSK is a collection of tools (icat, fls, mmls, blkls...) therefore I was using `icat` to test its presence within the appliance. How could I do it better? Shall I call it `optional = Some "sleuthkit"` and then in the code check for "icat" instead of using the given parameter? Is this considered a "clean" solution? If so I'll provide patch.
Rich.