On Sat, Feb 20, 2016 at 11:26:09AM +0300, Roman Kagan wrote:
Give the caller certain control over what kind of interface to use for virtual disks, network and video cards upon conversion.
For that, make convert functions accept additional rcaps parameter containing an object with optional capabilities similar to the ones produced on output, with None indicating that the decision is left to the convert function itself.
To facilicate review, this patch unconditionally passes rcaps with no preferences; populating it with more sensible values is done in a followup patch.
Signed-off-by: Roman Kagan <rkagan@virtuozzo.com> ---
Notes: v2: - use match instead of mixing match and if
I find the Windows_virtio.install_drivers function considerably easier to follow now, thanks. Rich. -- Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones Read my programming and virtualization blog: http://rwmj.wordpress.com libguestfs lets you edit virtual machines. Supports shell scripting, bindings from many languages. http://libguestfs.org