On 08/10/2018 07:00 AM, Pino Toscano wrote:
When erroring out about duplicated parameters, say "more than once" instead of "twice", since there can be more than two repeated parameters.
Thanks to: Xiaodai Wang ---
+++ b/generator/fish.ml @@ -367,7 +367,7 @@ let generate_fish_run_cmds actions () = pr " }\n"; pr "\n"; pr " if (optargs_s.bitmask & this_mask) {\n"; - pr " fprintf (stderr, _(\"%%s: optional argument \\\"%%s\\\" given twice\\n\"),\n"; + pr " fprintf (stderr, _(\"%%s: optional argument \\\"%%s\\\" given more than once\\n\"),\n";
Bikeshed wordsmithing for shorter lines: bar: optional argument "foo" repeated is a bit shorter... -- Eric Blake, Principal Software Engineer Red Hat, Inc. +1-919-301-3266 Virtualization: qemu.org | libvirt.org