Hello Richard,

Sahara uses python3.6, so I am using libguestfs 1.40.2. I downloaded guestfs library with this command "pip3.6 install http://download.libguestfs.org/python/guestfs-1.40.2.tar.gz".
The output of libguestfs-test-tool "===== TEST FINISHED OK ====="

This is the sahara-image-pack code file which gives error when calls the object of guestfs, https://github.com/openstack/sahara/blob/stable/ussuri/sahara/cli/image_pack/api.py#L77


Richard W.M. Jones <rjones@redhat.com>, 28 Kas 2020 Cmt, 12:50 tarihinde şunu yazdı:
On Sat, Nov 28, 2020 at 02:56:12AM +0300, İzzettin Erdem wrote:
> Hello Richard,
> I am working on OpenStack Sahara for a year and Sahara uses libguestfs for
> creating images according to the given .yaml file (sahara-image-pack bianry). I
> used this binary -and it worked- 6 months ago and after some version upgrades
> I've needed it again. When I try to create images I am taking errors from
> libguestfs.
> I did some research and in I found "sh" function in the guestfs.py file.
> Sahara-image-pack is using this function and sends it some commands but this
> function throws errors below. I tried to solve and did some tries to execute sh
> function with guestfs object but still the same.
> Main error is "guestfsd: error: /bin/sh: Exec format error". There is detailed
> logs below.
> I am kind of newbie, can you help me, please?
> http://paste.openstack.org/show/800516/
> http://paste.openstack.org/show/800517/

What version of libguestfs?  Where did you get it from?
What is the output of "libguestfs-test-tool"?


Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
Read my programming and virtualization blog: http://rwmj.wordpress.com
virt-p2v converts physical machines to virtual machines.  Boot with a
live CD or over the network (PXE) and turn machines into KVM guests.