Hi all,

It seems guestmount always fails to flush changes to the mounted qcow2 snapshot.

To reproduce this problem:
1. take an external snapshot for a qcow2
2. guestmount the snapshot
3. do some changes, for example: `echo 123 > /test; cat /test`, right now /test can be seen created and containing the right content
4. fusermount -u {mount-point}
5. virt-cat changed file, for the example above, sometimes /test doesn't exist, sometimes /test does exist but has no content

My libguestfs version is 1.20.11, and it's running on CentOS 6.6.

I tried several ways to work this around, but none of them worked.

I suspect it's a cache problem, so I tried to wait a while before umounting the image, sometimes this way works, sometimes it doesn't.

I also looked into the documentation for syncing and caching options, I tried to mount the image with fuse options like:
guestmount -o direct_io -o sync -o sync_read -o big_writes -w
no luck either.

What could be the cause? Is mounting a snapshot a problem?