I'm trying to build fedora-27 image for testing uploads:

$ virt-builder fedora-27 -o /var/tmp/fedora-27.img
[  25.2] Opening the new disk
virt-builder: error: libguestfs error: bridge ‘virbr0’ not found.  Try 

  brctl show

to get a list of bridges on the host, and then selecting the
bridge you wish the appliance network to connect to using:

  export _SETTINGS=network_bridge=<bridge name>

I don't want to add bridges to my new fresh oVirt test host, and
remember that this used to work previously without the bridge.

So I tried the usual "fix" (I know it should not be used in production):

$ export LIBGUESTFS_BACKEND=direct

And for some reason this works now:

$ virt-builder fedora-27 -o /var/tmp/fedora-27.img
[  41.2] Finishing off
                   Output file: /var/tmp/fedora-27.img
                   Output size: 6.0G
                 Output format: raw
            Total usable space: 5.3G
                    Free space: 4.4G (81%)

How LIBGUESTFS_BACKEND is related to the bridge? why do we need
the bridge for building an image?